Home » VintageKustom.com » Replacement Part Suggestions » Kasino Bass Head (Model 250 Bass, Bad potentiometer)
Kasino Bass Head [message #27035] Mon, 15 October 2018 10:47 Go to next message
Drummer61 is currently offline  Drummer61
Messages: 1
Registered: October 2018
Junior Member
Hello, I am new to this site. Just looking for a little feedback. I recently was given a Kasino model 250 bass, bass head. I conected it to a cabinet and it seems to play fine. the only problem is when I touch the push/pull knob, it sounds like it is wanting to short out or not grounded properly. Just wondering how to check and see if it is truly bad and where to purchase a new replacement. the numbers I see on it are 133-0056-00 then a little over it has 137- mexico. Any feedback would be greatly appreciated. thanks
Re: Kasino Bass Head [message #27036 is a reply to message #27035] Mon, 15 October 2018 12:32 Go to previous messageGo to next message
chicagobill
Messages: 1890
Registered: April 2003
Senior Member
Welcome to the place.

I'm not sure that I understand what you are describing as the problem, but cleaning the pot with a good quality electronics cleaner like DeoxIt would be my first suggestion. You can also see if the pot has a broken solder connection to the pc board.

As for replacements, it would have to come from another amp, as there really are no off the shelf repair parts anymore.

Again welcome.
Re: Kasino Bass Head [message #27037 is a reply to message #27035] Tue, 16 October 2018 06:07 Go to previous message
stevem is currently offline  stevem
Messages: 4112
Registered: June 2004
Location: NY
Senior Member
I have the same question Bill does about your post, are you saying that when you pull out/ turn on the function that switch does that the function that switch section does in sound is intermittent, or just the action of touching that pot will make for crackle and noise?
If it's the latter then as Bill posted that pot could just need a cleaning, or it could be a bad solder connection from that pot to the board.

One of the problems with cleaning and lubing the pots in these post 1970 made amps is that they are soldered to the circuit board with the open slot you need to spray the cleaner/ lube into facing the board.

I have a old flexible hose I use to get in there , but you may just have to unsolder the pot from the board to have access to spray cleaning it out right..
Previous Topic: 1N3754 bias diode
Goto Forum:
  


Current Time: Wed Nov #d 00:32:13 EST 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.9.