Home » VintageKustom.com » Replacement Part Suggestions » Blue On Off Switch (Is it a bulb or replace the entire assembly?)
Blue On Off Switch [message #27470] Mon, 05 August 2019 17:18 Go to next message
Ray is currently offline  Ray
Messages: 2
Registered: August 2019
Junior Member
Hey Folks,
I just bought a 300-5 PA system. The power comes on OK but the Blue light doesn't come on. Replace bulb or switch?

Also the system has 2 speaker cabs with 2 15" speakers and a horn. The cabs are 2K +1HP, anyone have information on these? They are very heavy!!

Thanks,
Ray
Re: Blue On Off Switch [message #27473 is a reply to message #27470] Wed, 07 August 2019 05:56 Go to previous messageGo to next message
stevem is currently offline  stevem
Messages: 4198
Registered: June 2004
Location: NY
Senior Member
Hello!
In the 300 head as with all the metal face amps the bulbs are in the switch behind the blue lens.
If you pm me will pm you to get your email adress so I can send you pictures and instructions on how to safely change out the mini bulb without breaking the switch as some times takes place.

Those are one of the correct optional speaker cabinets you could get with that 300 pa head.
They are loaded with Kustom / Eminrnce made 15" drivers and a Altec Lansing horn driver..

If from this site's main page you go to the Literature section and then hit the more T&C tab you will find the Kustom PA brochure that has pictures and info on this gear.

[Updated on: Wed, 07 August 2019 06:01]

Report message to a moderator

Re: Blue On Off Switch [message #27474 is a reply to message #27473] Wed, 07 August 2019 07:41 Go to previous message
Ray is currently offline  Ray
Messages: 2
Registered: August 2019
Junior Member
Thank you very much! The people at Kustom were no help.

my email is rdjennings335@yahoo.com

The system was sitting in a barn for 10 years with the covers on. It looks almost showroom condition, the goldish sparkle is perfect, the grill cloth
is excellent the horns are great. The only issues are the POTS are very scratchy, the blue lights for the on/off and Polarity switches do not work and #1 channel doesn't work. All other channels are good. It will be great to see the literature so I know what does what. The speakers are 2X15 Altecs and 2X15 Stock Kustom, they sound great.

Thank you again and any information is appreciated.

Ray
404-664-3232
Previous Topic: Schematic
Goto Forum:
  


Current Time: Mon Aug #d 19:33:37 EDT 2019
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.9.