Home » VintageKustom.com » Repairing Kustom Amps » K100 2 Questions (K100 2 1/2 volume and hiss)
K100 2 Questions [message #27723] Tue, 10 March 2020 21:49 Go to next message
Dutleydurite is currently offline  Dutleydurite
Messages: 3
Registered: March 2020
Junior Member
Hello all! I have replaced several of the input transistors with 2N3904 transistors. I have some volume, not just the faint signal I started with. I had to carefully dial the volume to around 10 o'clock at the start. The amp sounds farty and has little volume even when turned all the way up. Amp hissing is pretty significant at peak volume. I don't read schematics well. It's a pc104 board. I'm needing some help as I don't have somewhere to take it to. Thanks in advance.
Re: K100 2 Questions [message #27724 is a reply to message #27723] Wed, 11 March 2020 06:54 Go to previous messageGo to next message
stevem is currently offline  stevem
Messages: 4284
Registered: June 2004
Location: NY
Senior Member
You state the you changed the input Transistors, but There's is only one preamp input Transistor, that being Q100 which is a NPN type like the 2N3904 that you used, however the next Transistor Q101 is a PNP type.
Did you replace that with a 2N3904 also?
Re: K100 2 Questions [message #27725 is a reply to message #27724] Wed, 11 March 2020 19:25 Go to previous messageGo to next message
Dutleydurite is currently offline  Dutleydurite
Messages: 3
Registered: March 2020
Junior Member
I did not. That is reading as functional (diode on multimeter).
Re: K100 2 Questions [message #27726 is a reply to message #27723] Thu, 12 March 2020 06:20 Go to previous messageGo to next message
stevem is currently offline  stevem
Messages: 4284
Registered: June 2004
Location: NY
Senior Member
Your next step is to prove out that the preamp section has its needed voltage to run on, that being the + and - 8 volts as seen on the schematic.

This amp is a real PIA to work on with everything mounted to that one front board so take your time when making readings.
What I do with my hot meter probe is tape the metal shank up so only the very small tip is exposed.
Re: K100 2 Questions [message #27731 is a reply to message #27726] Sat, 14 March 2020 20:16 Go to previous messageGo to next message
Dutleydurite is currently offline  Dutleydurite
Messages: 3
Registered: March 2020
Junior Member
I drove a few hours to a repair shop. I easily found I was out of my league. I'll stick to guitar repair and changing tubes once in a while. Thanks for the help and resources. I just don't want to accident into voltage. Electricity gets beyond my comfort zone.
Re: K100 2 Questions [message #27733 is a reply to message #27723] Sun, 15 March 2020 06:28 Go to previous message
stevem is currently offline  stevem
Messages: 4284
Registered: June 2004
Location: NY
Senior Member
Sounds like a good decision, and he is welcome to use us as a resource in getting it back up and running if need be.

[Updated on: Sun, 15 March 2020 06:30]

Report message to a moderator

Previous Topic: Kustom 250-4
Next Topic: K150-6 pumps out DC voltage when powered on.
Goto Forum:
  


Current Time: Thu Jul #d 09:42:26 EDT 2020
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.9.