Home » VintageKustom.com » Repairing Kustom Amps » Krossroad 500 "pops" when powered off
Krossroad 500 "pops" when powered off [message #28767] Sat, 17 September 2022 13:22 Go to next message
rodak
Messages: 511
Registered: October 2001
Location: Georgia
Senior Member
I've got this Krossroad 500 that I resurrected many years ago. When I got it, two of the power transistors were fried (one each from two different pairs), and the solder traces were pretty burned. I got it working again by just pulling out the other transistor in each pair and cleaning up the circuit board. It worked, and still works now, but lately it's taken to making a loud "pop" when I turn off the power. It's loud enough that I fear for the speakers' health. Of course, I have no schematics for the amp - do you guys have any suggestions about what the issue might be? I know the amp has a circuit that doesn't enable the speaker output until a couple of seconds after power-on, wondering if it's supposed to work in reverse at power-off, but isn't.

Also, comparing it side-by-side with my K200-2 with 3x12s, I've decided that I really don't care for the sound of the Krossroad, neither the amp nor the speakers. The 3x12 isn't even really a bass cabinet, but it sounds much better as a bass rig than the Krossroad, imho. It's beautiful green sparkle Naugahyde, but I'm thinking about selling it anyway. I've never really been thrilled with the sound, but I've only used it a few times since I bought it, something like 15 years ago, so I figured I just hadn't messed with it enough, but side by side with the K200, it just doesn't pass muster. I'd like to get that "pop" fixed first, though.


www.combo-organ.com

[Updated on: Sat, 17 September 2022 19:31]

Report message to a moderator

Re: Krossroad 500 "pops" when powered off [message #28768 is a reply to message #28767] Sun, 18 September 2022 08:12 Go to previous messageGo to next message
stevem is currently offline  stevem
Messages: 4739
Registered: June 2004
Location: NY
Senior Member
You need to replace the two big power supply main rail filter cans and maybe any other electrolytic type caps in the amp.

After just even replacing those main rail filters you will find it makes a far better bass amp!

The worst thing in the world you can do to these filters is just have the amp sit around unused!

That safety start up circuit can not work once the power is turned off, if it could, then yes you would not hear that power down pop.

[Updated on: Sun, 18 September 2022 08:36]

Report message to a moderator

Re: Krossroad 500 "pops" when powered off [message #28769 is a reply to message #28768] Sun, 18 September 2022 20:31 Go to previous messageGo to next message
rodak
Messages: 511
Registered: October 2001
Location: Georgia
Senior Member
Thanks, Steve! I had replaced those filter caps back when I first got the amp, but I'm not sure the caps I bought off eBay were new or NOS. Even so, they're probably at least 15 years old by now.

I think what I need to do is set up all my amps enough so I can easily turn them on and play a bit every couple of months or so. Thanks for the advice.



www.combo-organ.com
Re: Krossroad 500 "pops" when powered off [message #28770 is a reply to message #28767] Sun, 18 September 2022 20:36 Go to previous messageGo to next message
rodak
Messages: 511
Registered: October 2001
Location: Georgia
Senior Member
Turns out it's been 18 years since I repaired the 500:

http://www.vintagekustom.com/FUDforum/index.php?t=msg&th =769&rid=38&S=264633bf32f86dcdd195922125f056ed#msg_3 895


www.combo-organ.com
Re: Krossroad 500 "pops" when powered off [message #28771 is a reply to message #28767] Mon, 19 September 2022 05:40 Go to previous messageGo to next message
stevem is currently offline  stevem
Messages: 4739
Registered: June 2004
Location: NY
Senior Member
Leave it on for two days and see if the filters are able to re-form themselves.
It can't harm to try.
Re: Krossroad 500 "pops" when powered off [message #28772 is a reply to message #28767] Mon, 19 September 2022 10:03 Go to previous messageGo to next message
rodak
Messages: 511
Registered: October 2001
Location: Georgia
Senior Member
well, worth a shot, I guess,thanks! Only problem is the fan noise might become annoying. Maybe I'll set it out in the garage Wink


www.combo-organ.com
Re: Krossroad 500 "pops" when powered off [message #28773 is a reply to message #28767] Mon, 19 September 2022 18:34 Go to previous message
stevem is currently offline  stevem
Messages: 4739
Registered: June 2004
Location: NY
Senior Member
Open it up and unpower the fan, it's not needed to just idle the amp anyway and will save the fan from hours of unneeded use.
Previous Topic: 250-4
Next Topic: Frank schematic needed - PC101
Goto Forum:
  


Current Time: Sun May 26 02:39:02 EDT 2024
.:: Contact :: Home ::.

Powered by: FUDforum 3.1.3.