VintageKustom.com
VintageKustom.com is your source for literature and information on the tuck-and-roll vintage Kustom amps from the 60's and 70's, as well as their related products such as guitars and organs . We provide a webboard for help with kustom gear history, technical information and repairs as well as discussions with other collectors.

Home » VintageKustom.com » Comment Board » Need info/advice: K250-1 and K400-1 (Looking for info on these setups)
Show: Today's Messages :: Polls :: Message Navigator
Switch to threaded view of this topic Create a new topic Submit Reply
Need info/advice: K250-1 and K400-1 [message #29238] Sun, 05 May 2024 19:36 Go to next message
Default is currently offline  Default
Messages: 2
Registered: May 2024
Junior Member
Hi all, been stalking the page for a while since I fell into my Kustom K250-1 and 118 cab. I've got questions about that one, but Im about to pick up a K400-1 with the 2 triple 15" cabs.

On the K250, it has the 3 prong cord done but I'm a little worried about the "death cap" I've heard mentioned. Also, the polarity switch on the front no longer moves, not that I've had a need to move it, but I've read conflicting things about when the cord upgrade gets done something is done to that button to disable it and others have said that's not the case etc. Just looking for some clarity.

Also, this amp (I use it for bass) seems to get "over driven" in tone fairly quickly. Im not an amp tech but I was wondering if this is something I could dial in better to mitigate?

Lastly with this amp: A while back I was doing some a/b testing between 2 different heads/cabs and unplugged the cab from the head, but forgot to turn the power off. When I went to grab the guitar cable from the front I got a very mild shock. Is that normal? Doesn't happen any other time when things are plugged in as normal.



On to the K400-1. I'm picking this up in the morning, I know nothing about it aside from it works and has the older 2 prong cord (which I plan on updating). I've looked thru the literature and pics but cant seem to find quite this exact model number listed anywhere, but I can see similar looking setups.


Would love info on both of these, if there's a how to guide I havent come across yet on what to do to update these to make them safe please let me know. I love these amps and feel like I'm in a downward spiral of a rabbit hole on these...


Re: Need info/advice: K250-1 and K400-1 [message #29240 is a reply to message #29238] Tue, 07 May 2024 06:39 Go to previous message
stevem is currently offline  stevem
Messages: 4745
Registered: June 2004
Location: NY
Senior Member
These amps want a 4 ohm speaker load to produce there full 125watts of clean output,
Is your 18" speaker the original?
In terms of volume and clean punch the amp May need to have its two main power supply filters replaced, especially if the amp has sat for long periods without being powered up.

When the mod is done to add a grounded power cable all that needs to done is to cut the death cap lead off at the switch and bolt down the ground wire from the new power cable to the chassis.
This assumes that the hot and neutral of the new cable are hooked up right, as in white to white and black to black

Why you got the shock would lead me to think that one of the two amps is not grounded right, or the outlet one of them was plugged into was not grounded .

What does the K400 have 4 channels or just two?
  Switch to threaded view of this topic Create a new topic Submit Reply
Previous Topic: Slant front vs straight front cabinets
Next Topic: AI-generated eBay description?
Goto Forum:
  

-=] Back to Top [=-
[ Syndicate this forum (XML) ] [ RSS ] [ PDF ]

Current Time: Thu Jun 13 23:59:05 EDT 2024