Home » VintageKustom.com » Comment Board » need speaker info
need speaker info [message #4988] Sun, 24 October 2004 14:56 Go to next message
shadow is currently offline  shadow
Messages: 21
Registered: October 2004
Junior Member
i need to pick some brains on what speakers my 3-15 cab has..all i can find is cts on the speaker plug plate the speakers say kustom electronics.. the #'s on the large square magnets are 5815113...16ohm.....137-7104...
and 038-0004-00.... on the cone i think i read t503-g3... does anyone know if they were made by kustom or are they another brand built by another company for kustom ..thanks for any info you can fill in here ... shadow.... also i'm kinda dumb on the kustoms .. i assume this is gonna be a guitar cab and not a bass cab ?? i have looked thru some old adds and don't find one that gives the 3 15's cab as being for guitar thanks again ...

[Updated on: Sun, 24 October 2004 15:57]

Report message to a moderator

Re: need speaker info [message #4989 is a reply to message #4988] Mon, 25 October 2004 00:43 Go to previous messageGo to next message
voided3 is currently offline  voided3
Messages: 200
Registered: July 2004
Senior Member
Hello. You have a CTS loaded bass cab. The 137 in 137-7104 is the CTS factory code and the 7104 means the fourth week of 1971. CTS speakers were also used in some Fender amps too, and for a bit of trivia, i heard/think CTS stands for Central Telephone Service; go figure. They sound pretty good for guitar too if you crank the treble on the amp you are using. Kustom did make 3-15 guitar cabs as well as PA and bass cabs, so it was a fairly widespread format. Good luck!
Frank head transformer wires [message #4995 is a reply to message #4989] Tue, 26 October 2004 10:10 Go to previous message
teleman is currently offline  teleman
Messages: 38
Registered: June 2004
Member
Wanted to do new post but there was no submit button in that mode. I've typed and lost 2 "new topic" posts so I'll get to the point. On my Frank head with verb and trem 2 purple wires that exit the huge transformer have come loose from what I think is the bridge rectifier where there are 2 terminals that have the same color (purple) wires attached. The loose wires are the right length to reach these terminals but which goes where? I have a shematic but can't see this on it. Please reply
if you can help. Thanks, Jim (teleman)
Previous Topic: Kustom 400
Next Topic: My Hat's off to Kustom!
Goto Forum:
  


Current Time: Sun Sep #d 19:13:53 EDT 2020
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.9.