Home » VintageKustom.com » Replacement Part Suggestions » Steve or ChicagoBill please help
Steve or ChicagoBill please help [message #23524] Wed, 29 July 2015 13:48 Go to next message
Kustom_Bart is currently offline  Kustom_Bart
Messages: 601
Registered: October 2010
Location: Greenville, MichiGUN
Senior Member
looking for transistors for K100 they are the ones for q126 rca 38869 and q127 rca 38870 is there another part that will cross for these two parts that you know of off hand? Or is there a supplier for these two pieces that you know of.

Thanks,
Bart
Re: Steve or ChicagoBill please help [message #23525 is a reply to message #23524] Wed, 29 July 2015 16:26 Go to previous messageGo to next message
chicagobill
Messages: 1985
Registered: April 2003
Senior Member
Those part numbers are the main driver transistors for the power amp. I've been using a 2N3440 for the NPN (38869) and a 2N5415 for the PNP (38870).

They need to have a small heat sink attached to the cases.

Edit: I just looked up these part numbers and now the 2N5415 is only being made by one company and they want 12.00 apiece for them.

I guess it's time to switch over to a TO-220 case transistor like a TIP41c/TIP42c. Or maybe a plastic cased one like the MJE340/MJE350. Unfortunately the pinouts are different and will be harder to fit in position.

[Updated on: Wed, 29 July 2015 17:10]

Report message to a moderator

Re: Steve or ChicagoBill please help [message #23527 is a reply to message #23524] Wed, 29 July 2015 19:53 Go to previous messageGo to next message
stevem is currently offline  stevem
Messages: 4532
Registered: June 2004
Location: NY
Senior Member
Why not the NTE129 and 129, there's tons of these!
Re: Steve or ChicagoBill please help [message #23530 is a reply to message #23527] Thu, 30 July 2015 11:28 Go to previous messageGo to next message
Kustom_Bart is currently offline  Kustom_Bart
Messages: 601
Registered: October 2010
Location: Greenville, MichiGUN
Senior Member
Thanks guys, my guy was trying to use the 128 and 129 and it wouldn't work, I am guessing the 128 is the issue? I did forward the info to him and he will know what to do. He has been repairing Kustoms for Pleat and I for years, this is a K100 head that belongs to Pleat, so now it will live again. Smile
Re: Steve or ChicagoBill please help [message #23535 is a reply to message #23524] Thu, 30 July 2015 13:47 Go to previous messageGo to next message
stevem is currently offline  stevem
Messages: 4532
Registered: June 2004
Location: NY
Senior Member
The 128 would not work, or it failed?
Re: Steve or ChicagoBill please help [message #23537 is a reply to message #23535] Thu, 30 July 2015 17:00 Go to previous messageGo to next message
Kustom_Bart is currently offline  Kustom_Bart
Messages: 601
Registered: October 2010
Location: Greenville, MichiGUN
Senior Member
He installed a 128 and a 129 respectively and the amp was motor boating. So he wanted to try something different. Any ideas or advice?

[Updated on: Thu, 30 July 2015 17:02]

Report message to a moderator

Re: Steve or ChicagoBill please help [message #23538 is a reply to message #23537] Thu, 30 July 2015 21:46 Go to previous messageGo to next message
pleat is currently offline  pleat
Messages: 1431
Registered: June 2004
Location: Belding, Mi
Senior Member
Been busy but the amp is question is the K100-2 reverb head. I thought I had given him all the cross transistors but talking with Kustom Bart today I must have missed some.

pleat
Re: Steve or ChicagoBill please help [message #23542 is a reply to message #23524] Fri, 31 July 2015 06:45 Go to previous message
stevem is currently offline  stevem
Messages: 4532
Registered: June 2004
Location: NY
Senior Member
What else was replaced other than the transistors?

Is it the driver board that is motorboating ?
If the tech disconnects the signal input to the driver board does the amp still motorboat ?
A bad electrolytic coupling or gain cap could make for the same issue , or maybe one of those two driver transistors are way above spec !
Previous Topic: Plastic Handle Inserts
Next Topic: Kustom Pro 3-W bins - need a new horn driver
Goto Forum:
  


Current Time: Thu May #d 12:25:31 EDT 2022
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.9.