Home » VintageKustom.com » Repairing Kustom Amps » Help needed to troubleshoot Kustom PA 200 Channels (kustom 200 PA Repair)
Help needed to troubleshoot Kustom PA 200 Channels [message #25647] Mon, 17 October 2016 19:35 Go to next message
bproctor is currently offline  bproctor
Messages: 11
Registered: December 2015
Location: BOSTON
Junior Member
Hi Everyone.
I am finally getting around to fixing my Kustom 200 PA Head. Channels 2 and 4 are dead. I blew out the dust and applied deoxit to the pots. How do i check capacitors and or transistors. Sound appears to be OK from the other channels.
Thanks,
Brian
Re: Help needed to troubleshoot Kustom PA 200 Channels [message #25648 is a reply to message #25647] Tue, 18 October 2016 06:15 Go to previous messageGo to next message
stevem is currently offline  stevem
Messages: 4284
Registered: June 2004
Location: NY
Senior Member
Can you solder, do you have a tube type solder sucker,can you read a schematic and do you have a volt / ohm meter and know how to test transistors?

[Updated on: Tue, 18 October 2016 06:18]

Report message to a moderator

Re: Help needed to troubleshoot Kustom PA 200 Channels [message #25650 is a reply to message #25648] Wed, 19 October 2016 06:00 Go to previous messageGo to next message
stevem is currently offline  stevem
Messages: 4284
Registered: June 2004
Location: NY
Senior Member
Even if you can just solder and unsoldering cleanly , changing out the first gain stage transistor will likely get both channels up and running , and the transistors these days are so cheap that it's fine to just shot gun the preamp boards and not even tests the transistors you yank out!
Re: Help needed to troubleshoot Kustom PA 200 Channels [message #25651 is a reply to message #25647] Wed, 19 October 2016 08:28 Go to previous messageGo to next message
bproctor is currently offline  bproctor
Messages: 11
Registered: December 2015
Location: BOSTON
Junior Member
Thanks for the help.
I am OK at soldering, and have a multi-meter.
My neighbor is a whiz at electronics repair, and I will probably have him to the surgery.

I am just looking to do the leg work so that he has the information he needs (schematics, usual suspects, etc).

As far as the gain stage transistor is concerned, is there one of these per channel? This would be the first transistor after input.

Looks like the schematic links are down. I will try to print this out when it becomes available.

Thanks again


Re: Help needed to troubleshoot Kustom PA 200 Channels [message #25653 is a reply to message #25647] Wed, 19 October 2016 09:17 Go to previous messageGo to next message
stevem is currently offline  stevem
Messages: 4284
Registered: June 2004
Location: NY
Senior Member
The schematic section of this site is working fine, as I just tryed it.
You need to have your tech friend look at the PC105 schematic and change out transistor Q100 next to the boards volume pot .
Re: Help needed to troubleshoot Kustom PA 200 Channels [message #25654 is a reply to message #25647] Wed, 19 October 2016 12:10 Go to previous messageGo to next message
chicagobill
Messages: 1956
Registered: April 2003
Senior Member
If your friend is a whiz, then he should first be able to test the transistors to see if that is the problem.
Re: Help needed to troubleshoot Kustom PA 200 Channels [message #25656 is a reply to message #25647] Wed, 19 October 2016 16:23 Go to previous message
bproctor is currently offline  bproctor
Messages: 11
Registered: December 2015
Location: BOSTON
Junior Member
Great info. I will have him check it out and report back.
He mainly works on classic arcade video games, but this shouldn't be too much of a stretch
Thanks,
Brian
Previous Topic: Dead K 100 Piggyback
Next Topic: K 200B-2 low volume
Goto Forum:
  


Current Time: Thu Jul #d 10:03:26 EDT 2020
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.9.