Home » VintageKustom.com » Repairing Kustom Amps
    Replies Views Last message
  A-4 Repair
Unwanted distortion ( 1 2)
By: Jonomega3 on Sat, 27 January 2018
54 5340 Mon, 20 August 2018 12:27
By: stevem
  K100-2 Reverb Issue
Reverb doesn't work - return OK but send apparently no good
By: Lovguitar on Fri, 17 August 2018
8 197 Sat, 18 August 2018 11:42
By: chicagobill
  K200B-2 tremolo is weak and pops when switched
Looks like the classic Fender "Harmonic Vibrato"
By: Saransk on Fri, 20 July 2018
8 494 Mon, 06 August 2018 19:33
By: chicagobill
  K200B-2 Both Preamps bad?
Low - No output from preamps
By: Saransk on Mon, 09 July 2018
6 411 Fri, 20 July 2018 12:52
By: Saransk
  K200 B4
No Volume...A little smoke! Help needed!
By: sskydiver1 on Tue, 17 July 2018
5 197 Thu, 19 July 2018 14:23
By: sskydiver1
  K250-1 bass head
module input & ohms
By: oren hudson on Wed, 19 September 2012
19 10142 Mon, 16 July 2018 10:49
By: woodsey
  KUSTOM VIII S-R-S amplifier
Repair
By: Aeroscott821 on Mon, 25 June 2018
1 458 Tue, 26 June 2018 06:05
By: stevem
  Kombo II Parts
Looking for Parts source for Kombo II
By: Trumpet Man on Fri, 22 June 2018
2 280 Sat, 23 June 2018 20:22
By: Trumpet Man
  Reverb but no tremolo
Reverb but no tremolo
By: Rozzy on Wed, 06 June 2018
9 859 Tue, 12 June 2018 11:56
By: stevem
  Fired up my Kustom Amp For First time in 20+ Years
Kustom Repair
By: B-Dubs on Sat, 05 May 2018
18 1454 Thu, 31 May 2018 16:16
By: B-Dubs
Goto Forum:
  
Legend New Messages New Messages   No New messages No New messages   Locked (w/ unread messages) Locked (w/ unread messages)   Locked Locked   Moved to another forum Moved to another forum

Current Time: Mon Aug #d 19:57:15 EDT 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.9.