Home » VintageKustom.com » Repairing Kustom Amps
    Replies Views Last message
  K200 B4
No Volume...A little smoke! Help needed!
By: sskydiver1 on Tue, 17 July 2018
5 118 Thu, 19 July 2018 14:23
By: sskydiver1
  K250-1 bass head
module input & ohms
By: oren hudson on Wed, 19 September 2012
19 9949 Mon, 16 July 2018 10:49
By: woodsey
  K200B-2 Both Preamps bad?
Low - No output from preamps
By: Saransk on Mon, 09 July 2018
5 311 Fri, 13 July 2018 13:30
By: chicagobill
  KUSTOM VIII S-R-S amplifier
Repair
By: Aeroscott821 on Mon, 25 June 2018
1 367 Tue, 26 June 2018 06:05
By: stevem
  Kombo II Parts
Looking for Parts source for Kombo II
By: Trumpet Man on Fri, 22 June 2018
2 209 Sat, 23 June 2018 20:22
By: Trumpet Man
  Reverb but no tremolo
Reverb but no tremolo
By: Rozzy on Wed, 06 June 2018
9 774 Tue, 12 June 2018 11:56
By: stevem
  Fired up my Kustom Amp For First time in 20+ Years
Kustom Repair
By: B-Dubs on Sat, 05 May 2018
18 1263 Thu, 31 May 2018 16:16
By: B-Dubs
  Kustom X MPA Monural Power Amp
Kustom X Power Amp Loud Hiss
By: jammy5152 on Wed, 23 May 2018
6 413 Fri, 25 May 2018 05:57
By: stevem
  Kasino Concert Guitar Head/ Model Con-L
reverb and tremolo not working
By: leejy on Sun, 06 May 2018
2 336 Mon, 07 May 2018 12:34
By: chicagobill
  K200B head
It whistles.
By: Bob's Guitars on Wed, 18 April 2018
1 499 Thu, 19 April 2018 06:05
By: stevem
Goto Forum:
  
Legend New Messages New Messages   No New messages No New messages   Locked (w/ unread messages) Locked (w/ unread messages)   Locked Locked   Moved to another forum Moved to another forum

Current Time: Thu Jul #d 20:45:25 EDT 2018
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.5.