Home » VintageKustom.com » Repairing Kustom Amps
    Replies Views Last message
  K-200B-2 normal channel
By: slk854 on Thu, 28 July 2016
12 3283 Thu, 04 August 2016 08:08
By: slk854
  How can I stop reverb howling on K 100?
By: lassoharp on Thu, 07 July 2016
33 8745 Sun, 31 July 2016 16:14
By: stevem
  Cell Phone Interference
By: C4ster on Fri, 29 July 2016
5 1858 Fri, 29 July 2016 14:08
By: C4ster
  Help Removing the back off cab
By: Epidrake on Mon, 25 July 2016
21 5434 Thu, 28 July 2016 09:21
By: Epidrake
  Castors
By: slk854 on Fri, 22 July 2016
6 2061 Mon, 25 July 2016 11:33
By: slk854
  K250 Adding an Effects Loop
. . . .anybody ever tried this?
By: LeeNails on Sat, 25 June 2016
15 4071 Fri, 15 July 2016 06:43
By: stevem
  bulb blew out. Do I have to take it apart?
By: Epidrake on Sat, 09 July 2016
8 2364 Wed, 13 July 2016 20:33
By: Epidrake
  Reverb fix for early K100-2
No Q131 in my amp, so I found a workaround
By: Jerrybass1955 on Fri, 17 October 2014
3 2402 Mon, 11 July 2016 12:39
By: chicagobill
  k200-b1
input hash
By: bowalk6 on Mon, 20 June 2016
3 1572 Mon, 20 June 2016 14:26
By: stevem
  k100 2 has a steady hum
How to fix this
By: mjg3145 on Fri, 17 June 2016
2 1249 Sun, 19 June 2016 05:44
By: stevem
Goto Forum:
  
Legend New Messages New Messages   No New messages No New messages   Locked (w/ unread messages) Locked (w/ unread messages)   Locked Locked   Moved to another forum Moved to another forum

Current Time: Tue Jun #d 11:13:23 EDT 2020
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.9.