Home » VintageKustom.com » Repairing Kustom Amps
    Replies Views Last message
  K200B
Lost output
By: stevem on Wed, 05 April 2017
8 4447 Thu, 13 April 2017 14:31
By: irish77060
  K-250-4 head
Channel two took a crap
By: Iowa Boy on Mon, 03 April 2017
4 2053 Tue, 04 April 2017 09:14
By: stevem
  Krossroad 500 - "pop" when shutting off
By: rodak on Tue, 14 March 2017
2 1977 Wed, 15 March 2017 20:38
By: rodak
  Changes in capacitor values - from schematic
restoring
By: Saransk on Fri, 03 March 2017
5 2744 Mon, 06 March 2017 13:00
By: stevem
  K200 B5 PA head help
lots of questions
By: Drjones1106 on Wed, 01 March 2017
3 2216 Thu, 02 March 2017 06:12
By: stevem
  Turn on Thump and turn of "pop" K100C-8
working but....
By: Saransk on Sun, 26 February 2017
1 1421 Sun, 26 February 2017 17:17
By: chicagobill
  Kustom 100 C-6
right side has no signal
By: Bodean1 on Sat, 04 February 2017
21 13033 Fri, 10 February 2017 22:16
By: Bodean1
  Help
Blowing 100 ohm resistor
By: Kawiokie on Mon, 09 January 2017
29 44312 Mon, 16 January 2017 14:28
By: stevem
  Kustom cab
input jack
By: timmyshazam on Mon, 12 December 2016
1 2760 Tue, 13 December 2016 06:18
By: stevem
  Kustom Studio 2 valve (or series ) schematic
Studio 2 valve schematic
By: imJonWain on Thu, 24 November 2016
3 2238 Fri, 25 November 2016 08:25
By: stevem
Goto Forum:
  
Legend New Messages New Messages   No New messages No New messages   Locked (w/ unread messages) Locked (w/ unread messages)   Locked Locked   Moved to another forum Moved to another forum

Current Time: Wed Jul #d 03:13:44 EDT 2020
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.9.