Home » VintageKustom.com » Repairing Kustom Amps
    Replies Views Last message
  745 PA amp
crackling sound ( 1 2)
By: Iowa Boy on Sun, 28 September 2014
52 9426 Mon, 06 October 2014 06:29
By: stevem
  200A-4
200A-4 first gain transistors
By: norwegian on Sun, 21 September 2014
2 1030 Sun, 21 September 2014 21:40
By: norwegian
  K200b-6
Help its been a long time
By: Daytopper on Thu, 04 September 2014
15 5273 Sun, 07 September 2014 06:55
By: stevem
  250 tremelo, vibrato noise
By: freekey on Thu, 04 September 2014
5 1988 Fri, 05 September 2014 13:35
By: chicagobill
  K100-2 Tremolo
How does it work and what is wrong with mine!
By: Jerrybass1955 on Fri, 22 August 2014
13 3817 Fri, 05 September 2014 13:27
By: chicagobill
  Do I actually have a Frankenstein??
Thought it was a rev. 4 K100-2
By: Jerrybass1955 on Tue, 26 August 2014
6 2493 Wed, 27 August 2014 12:28
By: chicagobill
  K100-2 Hiss but no other output
Need help troubleshooting
By: Jerrybass1955 on Mon, 11 August 2014
33 13184 Fri, 22 August 2014 15:35
By: daveo@zrgmail.com
  trem-vib distortion on my k150-8 and k100-8
is this normal? any fixes?
By: ampfab on Sun, 10 August 2014
13 4678 Tue, 19 August 2014 09:35
By: ampfab
  745 PA head
hissing sound....tank rattling
By: Iowa Boy on Fri, 15 August 2014
3 1388 Sat, 16 August 2014 02:55
By: chicagobill
  Beefing Up Power Supply Caps
By: Jerrybass1955 on Fri, 15 August 2014
4 1673 Sat, 16 August 2014 01:22
By: daveo@zrgmail.com
Goto Forum:
  
Legend New Messages New Messages   No New messages No New messages   Locked (w/ unread messages) Locked (w/ unread messages)   Locked Locked   Moved to another forum Moved to another forum

Current Time: Fri Nov #d 17:53:34 EST 2019
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.9.