Home » VintageKustom.com » Repairing Kustom Amps
    Replies Views Last message
  Reverb fix for early K100-2
No Q131 in my amp, so I found a workaround
By: Jerrybass1955 on Fri, 17 October 2014
3 2431 Mon, 11 July 2016 12:39
By: chicagobill
  k200-b1
input hash
By: bowalk6 on Mon, 20 June 2016
3 1594 Mon, 20 June 2016 14:26
By: stevem
  k100 2 has a steady hum
How to fix this
By: mjg3145 on Fri, 17 June 2016
2 1269 Sun, 19 June 2016 05:44
By: stevem
  volume jump and weak reverb/tremelo
same
By: backbeat1967 on Fri, 17 June 2016
1 1132 Sat, 18 June 2016 02:11
By: chicagobill
  Transistors?
By: Shaun_Musings on Sun, 15 May 2016
6 2762 Tue, 17 May 2016 10:26
By: stevem
  Naguhide Repair/Touch-up
By: slk854 on Wed, 06 April 2016
17 6247 Thu, 05 May 2016 17:00
By: Kustom_Bart
  How do I change the pilot light in TR12L
TR12L is the recent little roll & tuck prectice amp.
By: sleepingtiger on Sat, 30 April 2016
6 2383 Sun, 01 May 2016 15:29
By: sleepingtiger
  Kasino U200
Which footswitch was used for this amp
By: evernole on Fri, 29 April 2016
2 1589 Fri, 29 April 2016 22:37
By: evernole
  Help with T&R HEAD
Please help me troubleshoot my amp
By: bproctor on Sun, 17 April 2016
6 2991 Tue, 19 April 2016 14:40
By: stevem
  To ground or not to ground?
Replacing stock power cord?
By: bmacdo on Sat, 14 February 2015
10 4745 Wed, 13 April 2016 21:59
By: efinger
Goto Forum:
  
Legend New Messages New Messages   No New messages No New messages   Locked (w/ unread messages) Locked (w/ unread messages)   Locked Locked   Moved to another forum Moved to another forum

Current Time: Sun Jul #d 04:37:11 EDT 2020
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.9.