Home » VintageKustom.com » Repairing Kustom Amps
    Replies Views Last message
  Krossroad 500 - "pop" when shutting off
By: rodak on Tue, 14 March 2017
2 1777 Wed, 15 March 2017 20:38
By: rodak
  Changes in capacitor values - from schematic
restoring
By: Saransk on Fri, 03 March 2017
5 2444 Mon, 06 March 2017 13:00
By: stevem
  K200 B5 PA head help
lots of questions
By: Drjones1106 on Wed, 01 March 2017
3 1861 Thu, 02 March 2017 06:12
By: stevem
  Turn on Thump and turn of "pop" K100C-8
working but....
By: Saransk on Sun, 26 February 2017
1 1229 Sun, 26 February 2017 17:17
By: chicagobill
  Kustom 100 C-6
right side has no signal
By: Bodean1 on Sat, 04 February 2017
21 11977 Fri, 10 February 2017 22:16
By: Bodean1
  Help
Blowing 100 ohm resistor
By: Kawiokie on Mon, 09 January 2017
29 42781 Mon, 16 January 2017 14:28
By: stevem
  Kustom cab
input jack
By: timmyshazam on Mon, 12 December 2016
1 2574 Tue, 13 December 2016 06:18
By: stevem
  Kustom Studio 2 valve (or series ) schematic
Studio 2 valve schematic
By: imJonWain on Thu, 24 November 2016
3 1927 Fri, 25 November 2016 08:25
By: stevem
  combo 2 organ
weak signal
By: jbass5 on Mon, 14 November 2016
1 1056 Tue, 15 November 2016 05:57
By: stevem
  any pics of a PC203 board?
By: gregp on Sun, 06 November 2016
7 2452 Mon, 14 November 2016 08:15
By: stevem
Goto Forum:
  
Legend New Messages New Messages   No New messages No New messages   Locked (w/ unread messages) Locked (w/ unread messages)   Locked Locked   Moved to another forum Moved to another forum

Current Time: Mon Oct #d 04:57:02 EDT 2019
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.9.