Home » VintageKustom.com » Repairing Kustom Amps » Kasino u100-p (Club) and u200-p (Concert) repair
Kasino u100-p (Club) and u200-p (Concert) repair [message #27417] Mon, 08 July 2019 00:49 Go to previous message
sgtph3n1x is currently offline  sgtph3n1x
Messages: 3
Registered: July 2019
Junior Member
I'm quite stumped, after alot of googling I decided to come here and see if you guys had a answer for me.

So I have 2 Kasino amplifiers, as of 4 hours ago my u100-p (Club) was fine until I powered it off lastnight, when I went to power it on it made the most horrendous buzzing sound I've ever heard as soon as the flip was switched. I did however noticed the light on the front was not illuminated which didn't strike me as odd considering the sound it made, So I decided to pull it apart and aside from the literal mouse nest I found inside... I noticed a capacitor was leaking.. (like BAD) which I followed the wires to see their destinations and one of the wires goes straight to that light.. anyways.. I am assuming it's that capacitor that is the source of my problem but I cannot for the life of me find one to replace it.

I can't even find a datasheet on it to find a comparable cap.. any help would be super awesome as this is my dads amp and it means alot to him. I'll post a picture of the cap below...

i.imgur.com/BL1FW7D.jpg

Also the u200-p has never worked since I got it, it just doesn't power on. I was going to attempt to rob parts out of it, but I noticed the caps in it were dramatically bigger, so my thing is where would be a good place to start?

 
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Troubleshooting a 250 model 1 Bass amp
Next Topic: 795 Speaker Recommendation
Goto Forum:
  


Current Time: Mon Mar #d 21:30:43 EDT 2020
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.9.